Adobe has issued another in a series of fixes to Premiere Pro CC’s media cache management features in the latest update, version 11.1.2. Also included in the new version is support for 10-bit footage from the Panasonic GH-5 and some improvements to the workflow for editing graphic and text elements, including bug fixes that affected copy-and-paste operations between Premiere and After Effects.

Some users had reported in Adobe’s online forum that they had lost footage after Premiere’s release of v11.1 earlier this year introduced a new feature designed to keep its media cache clear of older files that could eventually clog drives. Unfortunately for some users, the feature’s behavior was somewhat counter-intuitive and thus unpredictable, at least when the location of the cache had been changed from the default. In some cases, users reported at the Adobe forums, camera media had been deleted outright. An early-May update addressed the problem by restricting any deletions to files inside a folder structure that had been created by Premiere Pro, and the new fix further limits any deletions to certain file types and turns media cache management off by default.

In a blog post, Premiere Pro Product Manager Patrick J. Palmer published the following list of items that Adobe has addressed in the latest update.

Improvements to Graphics and Text editing workflows

  • Move and position a layer’s anchor more precisely with anchor point snapping: You can now snap the anchor point to the edges and center of the selected layer, as well as to interesting points on other graphic layers or the video frame itself.
  • Position your graphic elements more precisely:  Holding Shift when dragging layers in the program monitor will constrain movement to one dimension (horizontal or vertical)
  • Keyboard navigation improvements when editing text
    • Add characters to a selection with Shift + Arrow
    • Support for Home and End keys
  • Bug Fixes for copying and pasting graphic and text layers between Premiere Pro and After Effects

Stability and Performance

  • Timeline and waveform redraw freezes on older mac systems with large projects
  • Certain clips (1000 fps) will crash if you scrub.
  • Crash during playback of some growing files
  • Audio is deleted from timeline when performing flatten multicam
  • Premiere hangs on quitting when using the Trim Mode source clips
  • Improved AVC-I export performance
  • Improve Dynamic Link Text Template performance

Formats and File Support

  • Importing FCP XML file fails if it contains a placeholder due to some synthetic item unable to be translated.
  • Canon XC10 file shows garbled image when moving through clip
  • Certain QT file will not import
  • Failure to import some QuickTime reference movies
  • When Import MP4 video clip shot by Panasonic AG-UX180, audio is truncated at the end of clip on the timeline
  • AVCI files show yellow bar in timeline
  • Failure exporting 25fps interpreted footage
  • Artifacting when paused on RED R3D Helium Stills
  • When Importing Canon C500 RAW file recorded in Odyssey 7Q, Screen divided into two parts with color changed incorrectly
  • “Conversion problem” is alerted when playing FCP’s multiclip sequence
  • When Import long recorded MXF, Red Frame occurs and audio is lost in the timeline
  • If a project file from a different platform is used, proxy-generation fails Media Cache
  • Media Cache delete warning dialog is not modal, on Windows
  • Only specific cache files should be deleted for Media Cache policy
  • Option to Save Media Cache files next to original does not persist


  • No realtime updates when modifying bezier handles or parameter line in Effect Controls panel
  • Lumetri: Reset color wheels affects other Lumetri instances
  • Effect keyframes are lost with partial Ingest
  • Edits to Effect Control Panel keyframe paths fail to update until you release the mouse
  • Black line appears through the Effect Control Panel
  • Effect keyframes fail to paste at the targeted point in time Captions
  • Ghost Caption Track Item comes back after being deleted
  • Importing an STL file does not allow to modify the resolution during the import
  • Team Projects: Editing text in captioning is not recognized as a change Audio
  • Audio effect parameter modifications are not properly serialized
  • Distortion during audio scrub
  • Audio effect parameter modifications are not properly serialized
  • Audio gain settings in Premiere get rendered to audio files
  • Hang on stop with no audio device (Win only)
  •  Audio Waveform is misplaced in specific zoom levels
  •  Audio channel settings reset after relink media
  • Adding an essential sound preset to a clip on the timeline will cause AME to hang when adding it to the render queue Export And Render
  • Unable queue export jobs to AME if Home Folder is mapped
  • File exported via the same export preset that it was created from will fail with error compiling movie
  • When multiple files are exported with the same name, they import with the duration of the first file
  • Exporting an AAF with a PSD file causes error and failure to play timeline in Media Composer
  • Rendering a timeline with default Mpeg I-Frame preview format results in media pending if sequence was changed due to clip mismatch
  • Publish to Behance crashes when exporting out of Premiere Pro without tags and description


  • Remove Attributes Resets All Intrinsic Effects
  • Import to floating bin doesn’t go into bin
  • Double-click clip, in Thumbnail View, will not open in Source Monitor.
  • License dialog appears and disappears
  • Cart icon should not appear in Project section when user drag and drop licensed stock video
  • Graphics menu has enabled options in Onboarding Media Browser (only visible to new users from the Welcome Screen)
  • Source panel playhead not updated when entering timecode values
  • Share button does not light up when changes are done in captions panel
  • Premiere Pro is getting blocked by QuickHeal anti-virus
  • Extra material required for transitions is not transcoded for partial Ingest.
  • Make Subsequence does not work for Sequence opened from Media Browser
  • Wrong Image position during scrub and playback with 1/2 playback resolution
  • NDF Clip in Source Monitor sends DF value to external SDI monitor
  • Dropped frames of 4k60p single stream timeline when there is a gap between clips
  • Import Project with Image Sequence In/Out instances will often result in AME failing to encode for partial Ingest
  • ALE Metadata column for description is incorrect
  • On Win HiDPI the Events popup window is not scaled and is too small
  • Match Source (Rewrap) presets fail to transcode matching clips
  • Multicam View gets disabled after using Trim Mode
  • ims accelerator cause issue with duration change
  • Ingest Settings dialog sometimes appears after opening 11.0 Project
  • Submix tracks are missing their name in the Track Header

Adobe Premiere Pro CC: